Thanks for this discussion.
I came here trying to find out of I could rename presents without breaking my cart. The answer appears to be yes.
I have to say that names like "85x85_scaled_cropped" would drive me nuts. I can always adjust the actions on a display. I want to know "what is the context for this preset?" or put another way "Which images does this preset control?"
My issue is simply want a bit more "verbose" descriptions for clients using a crop tool which uses preset names to make a menu. So Product_Page and Product_Listing and Cart might work better for them (or not).
Anyway, to me this is like the difference between semantic markup and presentational markup. The current UC naming conventions are semantic, and the OP's suggestions are presentational. For me, I much prefer a semantic nomenclature for my presets, even if in the end, maybe some of them have the same set of actions.
1. I build a site that uses 85x85_scaled in my shopping cart and for my gallery thumbnails.
2. Now I decide those are kind of small for my gallery, so I bump them to 150x150.
3. Oops, I forgot that presentational setting is used for the cart too, so that's broken. Now I have to redo my theme to use a different preset.
So a vote for keeping it the way it is.
In terms of the namespace issue, I think the best thing would be to do like for module functios and just append uc_ to every preset.