2 replies [Last post]
WesleyTx's picture
Offline
Bug Finder
Joined: 09/14/2007
Juice: 89
Was this information Helpful?

Everything seems to be going smoothly with 7c so far, except that my change to "Pickup Type" under Shipping Quote Settings > Shipping Methods > Quote Methods > UPS isn't saved. It always reverts back to "Daily Pickup." And the debug output confirms that it indeed is being sent as such:

  <PickupType>
    <Code>01</Code>
  </PickupType>

(On a side note, it's a little annoying to have to enter one's UPS password every time I want to change a setting on that page. But that's incidental right now.)

Thanks!

Lyle's picture
Offline
AdministratoreLiTe!
Joined: 08/07/2007
Juice: 6855
Re: Pickup Type Isn't Taking

Yeah, that slipped by somehow. Change line 276 to

<?php
   
'#default_value' => variable_get('uc_ups_pickup_type', '01'),
?>

As near as I can tell, though, the value should have been saved even when it didn't look like it the next time you came to that page. Let me know if that doesn't help change the actual quote debug output.

WesleyTx's picture
Offline
Bug Finder
Joined: 09/14/2007
Juice: 89
Re: Re: Pickup Type Isn't Taking

That seemed to do it. Saved and sent!

On a related note, if I edit a product and look under Shipping Settings > Default Product Pickup Address, everything but the street address is reflected. I've double checked the default pickup address under Shipping Quote Settings and it's there.

Doesn't seem to be an issue in getting quotes, but might be a small bug to look into.

Thanks!