4 replies [Last post]
TechMan's picture
Offline
Joined: 07/22/2008
Juice: 3
Was this information Helpful?

Hi all,

I am trying to use the LinkPoint module. I keep getting this error:

We were unable to process your credit card payment. Please verify your card details and try again. If the problem persists, contact us to complete your order.

I'm using the test credit card number 4111111111111111.

What I'm not sure on is the correct path settings in my LinkPoint account for the
Submission Form URL, Confirmation URL and Failure Page.

I had LinkPoint working under OSCommerce without any problems.

Thanks for any help.

maui1's picture
Offline
Joined: 09/30/2008
Juice: 8
Some things to try

I had the same problems and found a couple of things that might help. If your current installation is on the same server that you had OSCommerce working on then you don't need to worry about opening port 1129, otherwise you should check with your server host to whitelist the linkpoint url and to open port 1129 to two way traffic.

The .pem file path setting needs to be an absolute path, such as /home/domain/public_html/path to your pem file/

I was getting nothing but the same error you got until I had my host open port 1129, then I started getting a different error Eye-wink Credit Card Denied, even though I tried several cards which I knew were all valid. In reading the forums here I found that one possible issue is sending the year as 4 digits when linkpoint wants to see only a 2 digit year.

I found most of these tips and the linkpoint_api file from here: http://www.ubercart.org/contrib/903 But this seems to be from a year ago according to the date on the initial post, and I have yet to find a modules directory on this site where, one would think, you could find all of the most current modules for Ubercart. If you could point me to such a directory I'd be grateful.

Good luck, and when you get it working please let me know.

BrianV's picture
Offline
Joined: 01/10/2008
Juice: 68
maui1 wrote:I have yet to
maui1 wrote:

I have yet to find a modules directory on this site where, one would think, you could find all of the most current modules for Ubercart. If you could point me to such a directory I'd be grateful.

Good luck, and when you get it working please let me know.

http://www.ubercart.org/contrib ?

backdrifting's picture
Offline
Joined: 10/03/2008
Juice: 373
Check your configuration ...

I'm using LinkPoint API as our gateway without issue. I put in our store #, path to PEM file, and set it to TEST mode with PREAUTH. Check to make sure you have the PEM file on your server in the correct location (specified in the LinkPoint module instructions).

Also make sure you're running in TEST mode when you use the test credit card #. I was given a different test cc # from LinkPoint than the one you're using - you may want to check with them for a test CC #, and exp. date to use.

I've also tested our account in Production mode with a real credit card # and it's working without issue.

-backdrifting

jonhardy's picture
Offline
Joined: 07/22/2011
Juice: 3
Not getting response from Linkpoint

Hi All

I am using link point payment gateway with 1129 port no, and my website server is shared server and it doesn't have 1129 port.

How can i use this payment gateway like "Paypal" .......i mean without using api ...redirecting to that linkpoint site and processing payment and return back to my site

Thanks
Jon