3 replies [Last post]
PeteRemixed's picture
Offline
Joined: 02/20/2012
Juice: 6
Was this information Helpful?

Hi, I'm attempting to test my upgrade from 6 to 7 and I come across this singular error:


Failed: FieldException: Attempt to create field name taxonomy_catalog which already exists and is active. in field_create_field() (line 85 of C:\xampp\htdocs\modules\field\field.crud.inc).

I've tried deleting the term and then updating after I had already run the update, that produced a constant error on the screen about argument #2 needing to be an array. I attempted to update everything else first and then update it and that did not fix the issue. I can't remember if I added this term in D6 or if it was ubercart.

Any help would be greatly appreciated. Thank you!

Regards,

-Peter

TR
TR's picture
Offline
Bug FinderFAQ ModeratorGetting busy with the Ubercode.
Joined: 11/05/2007
Juice: 3280
Re: [Drupal 7, UC 3.0] Upgrade from 6 to 7, receive error when u

This is already reported in the issue queue http://drupal.org/node/1428596. There's a work-around there. Any additional information you can provide there might help.

<tr>.
urbanx@drupal.org's picture
Offline
Joined: 10/29/2008
Juice: 30
Re: Re: [Drupal 7, UC 3.0] Upgrade from 6 to 7, receive error wh

thanks for a nod in the right direction, TR.

however, i don't see a workaround there. all i see is the issue report. i glanced through the issue queue and will do some more searching in a bit, but if you know the whereabouts of the workaround you refer to, i would be more grateful if you would be willing to post a link to it, as i am encountering the same difficulty.

many many thanks.

d.

Fuzzy Dunlop's picture
Offline
Joined: 08/23/2013
Juice: 12
Re: Re: Re: [Drupal 7, UC 3.0] Upgrade from 6 to 7, receive erro

I, too, upgraded from Drupal 6 to 7, and am having the same problem as urbanx. I've tried deleting all my vocabulary and starting from scratch, with a new catalog, but I still receive the same errors. On top of that, I'm now unable to save any changes to my store, either when I edit or add products. It just redirects me back to the list view for all my products. I am desperate for a solution and don't see one anywhere on the page for the previously posted drupal.org link.