2 replies [Last post]
uberjai's picture
Offline
Joined: 03/06/2013
Juice: 6
Was this information Helpful?

I get the following error when trying to update from 7.2 to 7.3 or 7.3 to 7.4

Error message
Update failed! See the log below for more information. Your site is still in maintenance mode.
ubercart

Error installing / updating
File Transfer failed, reason: Cannot create directory /public_html/sites/all/modules/ubercart

I have no issues updating any other modules. Can anyone offer some suggestions please.

Thanks in advance. (Feel free to ask for more info)

DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Re: Error installing / updating

This is a known bug in Drupal that has been around forever. See https://drupal.org/node/842620. It can happen when you use PHP 5.4.

There are numerous suggestions in that post (too many, actually). If none of them fix the problem, just manually delete the ubercart module directory and replace it with the new version of the ubercart module by unpacking or copying the new files into place. This sounds scary, but it's fine. Just make sure you're in maintenance mode when you do this.

uberjai's picture
Offline
Joined: 03/06/2013
Juice: 6
Hi Dan, Thank you for

Hi Dan,
Thank you for that. As it is a new site I decided to try just that in the meantime.. And it worked! So, I glad your advise confirms that was the right move & I'm not going nuts as I haven't found a fix either. I'm currently using php 5.3.22.