4 replies [Last post]
DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Was this information Helpful?

Here's a tricky one for Ubercart 7.x-3.4.

I am getting occasional reports from customers that they fill out the information on the Checkout page and click the "Review Order" button, but the page just reloads, returning them to the checkout page.

They get no error messages, and there's nothing in the log. If I call them and walk them through it, it works fine every time, so it's some sort of intermittent problem.

These customers (usually anonymous) do have abandoned carts that contain their shipping and billing information, which appears to be correct.

So, I don't even know where to start troubleshooting.

My current wild guess is that it's some sort of communications glitch with Authorize.net, but that's just a guess.

Has anyone heard of this one before? The vast majority of customers don't report any problems.

end user's picture
Offline
Joined: 01/11/2008
Juice: 1738
Re: Mysterious rare return to checkout page instead of order rev

I found this http://www.ubercart.org/forum/support/17853/argh_checkout_button_not_wor...

and http://drupal.org/node/863070

Some people have reported this also http://drupal.org/node/1231804

I have seen this happen on one of my test sites but don't remember what was causing it or if I fixed it.

DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Re: Mysterious rare return to checkout page instead of order rev

Thanks for the links. Unfortunately, none of them fits my situation.

In my situation, it's a problem going from the checkout page to the review order page. (In most of the posts, they couldn't get to the checkout page.)

Also, in my situation, the problem only happens rarely. (In the other posts, it always failed.)

Is there some way to turn on some sort of logging to catch this intermittent problem? I don't even have anything to troubleshoot.

DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Re: Mysterious rare return to checkout page instead of order rev

Ok, I got a hint from one of my customers. This one sounds slightly different, but possibly related.

She filled out the checkout form, then left the room for a while. When she came back, she hit the Review Order button.

This took her to the review order screen, but much of the information that normally shows up there was missing. So, no credit card info. When she tried to complete the order, she bounced back to the checkout page and had to enter her information again.

Her original order showed up as "Abandoned", and had her address and phone information, but no payment information.

Other customers never made it to the review order page.

Anyone know what's going on, here? Maybe some kind of timeout?

DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Another hint. The customer

Another hint.

The customer put the products in the cart, then went to the home page, which had a cart block on it.

She clicked on the checkout link from the cart block, so she went directly to checkout, skipping the cart page.

She filled out her address and payment information and hit "Review Order". This took her back to the site's home page, instead of the review order page.

This happened to her several times. Each time she got to the checkout page, she had to enter her address and payment information again.

Of course, when I called her, everything worked perfectly.