3 replies [Last post]
wprothero's picture
Offline
Joined: 01/26/2011
Juice: 56
Was this information Helpful?

I'm finally almost done upgrading from Drupal 6 to 7.
There is one error that I need to fix manually, because something fails in the update script.
All updates except the very last one worked without error. But....

The last update was:

---------------
1 pending update
uc_order module

7301 - Convert view invoices checkbox to permission.
-----------------

I got the following update error:
The following updates returned messages

uc_order module

Update #7301

Failed: PDOException: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'module' cannot be null: INSERT INTO {role_permission} (rid, permission, module) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2); Array ( [:db_insert_placeholder_0] => 2 [:db_insert_placeholder_1] => view own invoices [:db_insert_placeholder_2] => ) in user_role_grant_permissions() (line 3076 of /Applications/MAMP/htdocs/modules/user/user.module).

When I go to store/products/view, I get the following error:

EntityMalformedException: Missing bundle property on entity of type node. in entity_extract_ids() (line 7663 of /Applications/MAMP/htdocs/includes/common.inc).
The website encountered an unexpected error. Please try again later.

So, how can I fix this manually? I don't have that many products, and can rebuild the products, but what should I do to proceed from here? Since I can't view the products, I can't delete, set, fiddle, whatever.

Thanks in advance for any help.
Bill

Bill ScienceGuy

DanZ's picture
Offline
Joined: 08/07/2011
Juice: 1738
Asking Google to find "7301 -

Asking Google to find "7301 - Convert view invoices checkbox to permission" shows that this is a known issue. See http://drupal.org/node/1785090.

There appears to be a fix for it in the 7.x-3.x-dev version of Ubercart. Using that version should solve the problem.

Because of the way Drupal upgrades work, you might need to restore to the backup you took right before the upgrade, install the 7.x-3.x-dev, and upgrade from there (i.e., make sure you never touch 7.x-3.4).

wprothero's picture
Offline
Joined: 01/26/2011
Juice: 56
Re: Asking Google to find "7301 -

Thanks for that info. I'm out of town for a few days, but I'll take your advice and its good to know there's a fix.

Bill ScienceGuy

mezcal's picture
Offline
Joined: 04/07/2013
Juice: 3
Problem solved

I had the same problem but solved with the version mentioned for Danz, thanks.

This submission was made ​​by mezcal, thanks for your understanding.