3 replies [Last post]
natemelen's picture
Offline
Joined: 08/10/2016
Juice: 4
Was this information Helpful?

I am using Ubercart v3 on a Drupal 7 site (ubercart module 7.x 3-1.0). Upon completing an order I am getting 2 error messages (unable to send email: contact site administrator if problem persists). One error is for sending the order to the site administrator while the other is for sending the invoice to the customer. I am also using a webform on the site and using the SMTP Authentication module and it is sending emails just fine. I have all the appropriate fields in place, the workflow rules are set up to send an invoice to the administrator and to the customer. I have spent hours Googling a solution and have come up empty handed. Any help would be appreciated.

kathc's picture
Offline
Joined: 09/10/2016
Juice: 7
Re: Unable to send email

As above, apparently since the update to Drupal 7.50 our store has not been sending email. Orders are processed (payments also) but stop at Pending.

Other messages from the site (STMP Authentication tests, password resets, etc.) are coming through fine.

There are a number of errors generated at each order (apparently I can't post them here though).

Any help or advice would be appreciated (and any offers of paid assistance considered).

Kathryn

kathc's picture
Offline
Joined: 09/10/2016
Juice: 7
Re: Re: Unable to send email

The errors not included above were mostly about variable module, so I looked there, and there's a patch to the SMTP authentication module which lets my orders process to complete, and throw up an error for the user saying email could not be sent (but they can download their invoice, and we can see the order once it's processed, so that's progress).

kathc's picture
Offline
Joined: 09/10/2016
Juice: 7
Re: Re: Re: Unable to send email

Okay - the SMTP Authentication Support patch made more progress, but now it seems like my final problem is that the SMTP server is Office 365 and it's not authenticating properly when email is coming fro the store (all other messages are working fine).

So not ubercart (except for all of the crud brought up about D6 modules) or variable, or smtp modules (or the Drupal 7.50 upgrade that seemed to have started all of this, for me anyway).